CcpnForum
Assignment becomes unresponsive - Printable Version

+- CcpnForum (https://www.ccpn.ac.uk/forums)
+-- Forum: CcpNmr Analysis Version 3 (https://www.ccpn.ac.uk/forums/forumdisplay.php?fid=4)
+--- Forum: V3 General (https://www.ccpn.ac.uk/forums/forumdisplay.php?fid=8)
+--- Thread: Assignment becomes unresponsive (/showthread.php?tid=39)

Pages: 1 2


Assignment becomes unresponsive - Panagiota - 09-27-2019

Dear all,

While working on the assignment, some of the saved versions while loading become unresponsive with the message "mainWindow.clearMarks()" no matter what you are trying to do. Is there a fix for that?

Best,
Panagiota


RE: Assignment becomes unresponsive - Panagiota - 09-28-2019

(09-27-2019, 02:09 PM)Panagiota Wrote: And when loading the project I get the following error message:

Error reading project ccp.nmr.Nmr.Shift.checkValid: resonance:
       value cannot be None: <ccp.nmr.Nmr.Shift ['default', 1, None]>
WARNING: Error initialising object <CL:default>. 'NoneType' object has no attribute 'serial'1          (AbstractWrapperObject._initializeAll:929)


RE: Assignment becomes unresponsive - micaelsilva - 10-03-2019

(09-28-2019, 08:07 AM)Panagiota Wrote:
(09-27-2019, 02:09 PM)Panagiota Wrote: And when loading the project I get the following error message:

Error reading project ccp.nmr.Nmr.Shift.checkValid: resonance:
       value cannot be None: <ccp.nmr.Nmr.Shift ['default', 1, None]>
WARNING: Error initialising object <CL:default>. 'NoneType' object has no attribute 'serial'1          (AbstractWrapperObject._initializeAll:929)

Dear all,

I am using the CcpNmr AnalysisAssign version 3.0.0 updated in MacOS X. As Panagiota, I had the same problem, while working in backbone assignment, the "pick and assign" and "backbone assignment" modules become unresponsive (no navigation at all in the spectra). Also, the chemicalshiftlists "CL:default" turns out empty. Is there a solution for this problem?

Errors when loading the project:

WARNING: Error initialising object <CL:default>. 'NoneType' object has no attribute 'serial'1          (AbstractWrapperObject._initializeAll:929)
WARNING:  Ambiguous shortcut overload: W1. 

Error when I click in the residue to navigate in the spectra:

INFO   : mainWindow.clearMarks()                                                                       (Logging._info:109)

Best,

Micael 

Micael S. Silva, MSc
MolBioS PhD Student FCT - NOVA, Portugal
(Bio) Molecular Structure and Interactions by NMR Group UCIBIO@REQUIMTE


RE: Assignment becomes unresponsive - VickyH - 10-15-2019

Hi Panagiota and Micael,

is there some sort of pattern to this?
The best thing might be for you to send us an affected project (ccpnmr3@gmail.com), so we can have a look at it in more detail.

Thanks,
Vicky


RE: Assignment becomes unresponsive - Panagiota - 10-15-2019

(10-15-2019, 02:08 PM)Hi Vicky,Actually these errors were eliminated after the last updates.Thanks,Panagiota--------------------VickyH Wrote: Hi Panagiota and Micael,

is there some sort of pattern to this?
The best thing might be for you to send us an affected project (ccpnmr3@gmail.com), so we can have a look at it in more detail.

Thanks,
Vicky



RE: Assignment becomes unresponsive - micaelsilva - 10-18-2019

(10-15-2019, 02:08 PM)VickyH Wrote: Hi Panagiota and Micael,

is there some sort of pattern to this?
The best thing might be for you to send us an affected project (ccpnmr3@gmail.com), so we can have a look at it in more detail.

Thanks,
Vicky

(10-15-2019, 02:29 PM)Panagiota Wrote:
(10-15-2019, 02:08 PM)Hi Vicky,Actually these errors were eliminated after the last updates.Thanks,Panagiota--------------------VickyH Wrote: Hi Panagiota and Micael,

is there some sort of pattern to this?
The best thing might be for you to send us an affected project (ccpnmr3@gmail.com), so we can have a look at it in more detail.

Thanks,
Vicky

Dear Vicky,
 
I started a new project, and up to now, there is no error at all. In the project where the module becomes unresponsive, it seems a problem from a directly deletion of peaks from a peaklist and/or when I undo some action (command + z).

Best, 

Micael 


RE: Assignment becomes unresponsive - bosmith - 10-21-2019

We have hit a similar problem with the same error on startup. I've sent you the project in question.

Brian


RE: Assignment becomes unresponsive - VickyH - 10-23-2019

Hi All,

the issue seems to be if you "Undo" an assignment. (If the NmrAtom in question isn't already assigned to something else you can end up with an entry in the chemical shift table with no chemical shift associated with it - which the program doesn't like!) Hopefully, we'll be able to upload a fix to the Update Server soon. But in the mean time, it may be wise to remove assignments explicitly rather than using the Undo function. You can easily remove assignments with right-click / Deassign Peak(s) or in the Peak Assigner (shortcut AP) or by deleting an NmrAtom (though I notice that if you do this latter operation the other modules aren't automatically updated - only once you reopen or refresh them in some way - another bug!).

Vicky


RE: Assignment becomes unresponsive - bosmith - 10-24-2019

I think I found a solution to our broken project, but won't claim a full understanding of why it's a problem.

The error message comes from one of the checks in the setup of an instance of class Shift that happens at line 134895 of ccpnmodel/ccpncore/api/ccp/nmr/Nmr.py. By inserting a line to tell me what the _ID of the Shift that was problematic was, I could find it in the ccpnv3/ccp/nmr/Nmr/<longname>.xml file and it was an NMR.Shift that indeed had no NMR.Resonance.shifts that referenced it. Deleting the rogue NMR.Shift seems to restore the project to a workable state.

If Vicky's right about this coming from an undo (although we don't think so in this case) then the code is perhaps reversing the creating of the resonance, but not cleaning up the shift list?


RE: Assignment becomes unresponsive - bosmith - 10-25-2019

Cross-referencing an instance of this in the issue tracker:

https://bitbucket.org/ccpnmr/issue-tracker/issues/224/project-fails-to-open